Dropping Qt4 compatibility

Vatsinator version 0.2 was designed and built under Qt4, which was the most popular version of this framework a year ago. However, Qt5 offers a lot of new features and it is available on lastest Linux distributions. It was pointless to maintain Qt4 compatibility, as there are many changes in OpenGL usage, which Vatsinator uses a lot. The code looks terribly ugly, containing a lot of macros and wrapper functions.

What does it mean to me?

If you are a Linux user and you use an older distro, you may want to upgrade to the latest version prior to 1.0 release. If you use Windows, Mac or Android you need not to worry. Qt5 libraries will be shipped with the application.

Devel shot ver. 1.0

Although it’s been a while, you can keep calm – Vatsinator development is still on and there is no danger anybody will forget it. To prove what I state, I’d like to show you some still-warm shots from nightly builds. There is still a lot of work ahead, but version 1.0 is approaching!

Weather Forecast preview

Integrated weather forecast for the next week

EUroute NOTAM center ntegration

EUroute NOTAM center integration

Vatsinator Database integration

Vatsinator Database integration