Dropping Qt4 compatibility

Vatsinator version 0.2 was designed and built under Qt4, which was the most popular version of this framework a year ago. However, Qt5 offers a lot of new features and it is available on lastest Linux distributions. It was pointless to maintain Qt4 compatibility, as there are many changes in OpenGL usage, which Vatsinator uses a lot. The code looks terribly ugly, containing a lot of macros and wrapper functions.

What does it mean to me?

If you are a Linux user and you use an older distro, you may want to upgrade to the latest version prior to 1.0 release. If you use Windows, Mac or Android you need not to worry. Qt5 libraries will be shipped with the application.

Leave a Reply

Your email address will not be published. Required fields are marked *